Windows Explored

Everyday Windows Desktop Support, Advanced Troubleshooting & Other OS Tidbits

  • July 2011
    M T W T F S S
    « Jun   Aug »
  • Translate

  • Advertisements

Error Installing Older Versions of Flash Player

Posted by William Diaz on July 1, 2011

I found myself needing to install an older version of Flash Player for troubleshooting purposes. After uninstalling the current Flash Player, I encountered the following error when trying to install the older Flash Player: “The installation encountered errors: The version of Adobe Flash Player that you are trying to install is not the most current version…”
6-20-2011 12-47-20 PM The installer queries the version data in this key and compares it against the version being installed. This is Adobe’s way of insuring you do not install a version of Flash Player that is older than the version that is currently installed:
Ideally, when Adobe Flash Player is uninstalled, the version data in the registry should be removed(?). The registry data in question is located in HKLM\Software\Macromedia\FlashPlayerPlugin and has a string value equal to the most recent version of Flash Player that was installed:
To resolve, simply delete the FlashPlayerPlugin key and run the installation again.


Leave a Reply

Fill in your details below or click an icon to log in: Logo

You are commenting using your account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: